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Overview

This Guide is intended for use with Unibar® ELS Enterprise™ software.

Unibar ELS Enterprise is a fully web-enabled application that allows you to
print barcoded shipping, RFID, and other production labels directly to your
printers, using data from your organization’s own applications and databases.

Unibar ELS Enterprise is divided into functional areas called modules. Each
module contains related application functionality that lets you complete a set
of tasks necessary for creating labels. The modules of the application work
together to help you create labels. The modules of Unibar ELS Enterprise
include:

• Print

• Design

• Admin

Unibar ELS Enterprise Modules

You can navigate to all of the application main modules by using the applica-
tion header. The application header is located at the top of the Unibar ELS
Enterprise window and is visible from all pages within Unibar ELS Enter-
prise.
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Installation/Setup

To use the Unibar ELS Enterprise software you need a web browser and
Adobe® Flash® Player 10 or later.

Unibar ELS Enterprise has been tested running on the following platforms
(both 32-bit and 64-bit where applicable, unless otherwise noted):

Note: Unibar ELS Enterprise may work on any Microsoft Windows, Linux, or
UNIX platform that supports a Java Runtime Environment (JRE) version 1.6
or newer).

Specific questions about using Unibar ELS Enterprise on your platform can
be addressed by contacting the DSI Global Support Center. See contact infor-
mation below.

Americas-Based Clients (North, Central, and South America)
+1 (913) 696-4040

EMEA-Based Clients (Europe, Middle East, Africa)
+44 (0) 2033181584

AP-Based Clients (Asia Pacific)
+613 9001 5749
24 hours a day/7 days a week for support

E-mail: GlobalSupport@DSIonline.com

Web site – http://gsc.dsionline.com

- Windows Server 2003® - Oracle® Linux 6 (Intel)

- Windows Server 2008®
(including R2)

- Red Hat® Enterprise Linux®
6 (RHEL - Intel)

- Windows 7® - SUSE Linux® Enterprise 11
(Intel - 64-bit only)
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Windows Systems

Note: On a Windows 7® and Windows Server 2008® 64-bit systems, LPR monitor-
ing must be enabled in order to run Unibar ELS Enterprise.

 To enable LPR monitoring for Windows 7®

1. Navigate to the Windows Control Panel.

2. Click Programs, then Programs and Features, select Programs > Turn
Windows Features on or off.

3. Expand the Print and Document Services selection.

4. Check the box next to LPR Port Monitor.

5. Click OK.

 To enable LPR monitoring for Windows Server 2008

1. Click the Windows Start icon.

2. Right-click Computer, then select Manage.

3. Highlight Features.

4. Select Add Features.

5. Check the box next to LPR Port Monitor.

6. Click Next.

7. Click Install.

LPR Port Monitor appears in the Features list.
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 Download and stand alone installation for Windows

1. Select the appropriate file for your system (32 or 64-bit) to download from the
Unibar Web site (http://www.unibar.com) or the DSI Global Support Center
web site (http://gsc.dsionline.com).

2. On the File Download dialog box, select Save.

3. Save the *.exe file to the desired location. Take note of the folder where the
file is saved.

4. Once the file is saved, select Run.

5. Follow the installation Wizard prompts.

6. The default installation location is C:/Program Files/Unibar. You may desig-
nate a different installation location if desired.
The application will reside within a Unibar folder with an ELSEnterprise9
subfolder.

7. Once the installation procedure is complete, click Finish.

8. Navigate to the folder where the application is installed.
For example: C:/Program Files/Unibar/ELSEnterprise9

9. Open the bin folder and run StartELSEnterprise.bat.
(You can run StartELSEnterprise.bat by right-clicking the file and
selecting Open.)

10. Once you see the server startup message in the command window, open a web
browser and enter the following address — http://[server name]:[Port name]/
ELSEnterprise
For example: http://localhost:9010/ELSEnterprise

Note: Adobe Flashplayer 10 or later is required to run the application’s graphical
user interface.
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 To install as a service for Windows 7

For the Windows 7 operating system, you must have Administrator privileges
to install the application as a service.

1. Select the appropriate *.exe file for your system from the Unibar Web site
(http://www.unibar.com) or the DSI Global Support Center Web site
(http://gsc.dsionline.com).

2. On the File Download dialog box, select Save.

3. Save the *.exe file to the desired location. Take note of the folder where the
file is saved.

4. Once the file has been saved, select Close.

5. Navigate to the location where the application *.exe file is saved.

6. Right-click the *.exe file and select Run as administrator.
(If you see a User Accoun Control dialog box, select Yes.)

7. Follow the Installation Wizard prompts.

The default installation location is C:/Program Files/Unibar. You may desig-
nate a different installation location if desired.
The application will reside within a Unibar folder with an ELSEnterprise9
subfolder.

8. Once the installation procedure is complete, click Finish.

9. Click the Windows Start icon on the taskbar.

10. In the search field, type cmd and hold down Shift + Control as you hit the
Enter key.
A User Account Control dialog box appears.

11. On the User Account Control dialog box, click Yes. The Administrator
command window opens.
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12. On the command line (in the Administrator command window), navigate to
the folder where Unibar ELS Enterprise is installed and run the
installService.bat file.

For example: If you installed the application to the Program Files folder on
your C drive, type the following commands.

• c:

• cd \“Program Files”\Unibar\ELSEnterprise9\bin

• installService.bat

Note: When typing in the command prompt, you must use quotation marks around
any folder that has a space in the name.

13. Open the Services Manager Window.
(Press the Windows key + R, then type services.msc and click OK.)

14. Right click on ELSEnterprise and select Start.

15. Open a web browser and enter the following address:
http://[server name]:[Port name]/ELSEnterprise
For example: http://localhost:9010/ELSEnterprise
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 To install as a service for Windows Server 2003

1. Confirm that you have Administrative privileges.

2. Select the appropriate file for your system (32 or 64-bit) to download from the
Unibar Web site (http://www.unibar.com) or the DSI Global Support Center
Web site (http://gsc.dsionline.com).

3. On the File Download dialog box, select Save.

4. Save the *.exe file to the desired location.

5. Navigate to the location where you saved the application *.exe file.

6. Right-click the *.exe file and select Open.

7. Follow the Installation Wizard prompts.

The default installation location is C:\Program Files\Unibar. You may desig-
nate a different installation location if desired. (The application will reside
within a Unibar folder with an ELSEnterprise9 subfolder.)

8. Once the installation procedure is complete, click Finish.

9. Navigate to the Unibar folder and confirm that permissions for the individual
logged in during installation is set to Full Control.

• To check folder permissions, right-click on the Unibar folder and
select Properties.

• Select the Security tab.

• Highlight the Group or user name that is currently logged in.

• Confirm that the Full Control check box under the Allow column
is selected.

10. From the Start menu, select Run.

11. In the Open field, type cmd and press Enter.
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12. On the command line, navigate to the folder where Unibar ELS Enterprise is
installed and run the installService.bat file.

For example: If you installed the application to the Program Files folder on
your C drive, type the following commands.

• c:

• cd \“Program Files”\Unibar\ELSEnterprise9\bin

• installService.bat

Note: When typing in the command prompt, you must use quotation marks around
any folder that has a space in the name.

Note: If you receive an error when installing Unibar ELS Enterprise as a service,
check the permissions on the Unibar folder.

13. At the Start menu, select All Programs > Admin Tools
If you do not see this on your Start menu, open the Control Panel, then open
the Administrative Tools folder. Finally, open the Services folder.

14. In the Services window, right-click ELSEnterprise and select Start.
The Status column will change from being blank to reading “Started” once the
application has been started.

15. Open a web browser and enter the following address:
http://[server name]:[Port name]/ELSEnterprise
For example: http://localhost:9010/ELSEnterprise

You have the option to change the name of the service before installation by
opening the setVars.bat file in the bin directory and changing SetServi-
ceName=ELSEnterprise to a different name (SetServiceName=newname).
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 To install as a service for Windows Server 2008

1. Confirm that you have Administrative privileges.

2. Select the appropriate file for your system (32 or 64-bit) to download from the
Unibar Web site (http://www.unibar.com) or the DSI Global Support Center
Web site (http://gsc.dsionline.com).

3. On the File Download dialog box, select Save.

4. Save the *.exe file to the desired location.

5. Navigate to the location where you saved the application *.exe file.

6. Right-click the *.exe file and select Open.

7. Follow the Installation Wizard prompts.

The default installation location is C:\Program Files\Unibar. You may desig-
nate a different installation location if desired. (The application will reside
within a Unibar folder with an ELSEnterprise9 subfolder.)

8. Once the installation procedure is complete, click Finish.

9. Navigate to the Unibar folder and confirm that permissions for the individual
logged in during installation is set to Full Control.

• To check folder permissions, right-click on the Unibar folder and
select Properties.

• Select the Security tab.

• Highlight the Group or user name that is currently logged in.

• Confirm that the Full Control check box under the Allow column
is selected.

10. Click the Windows Start icon on the taskbar.
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11. In the search field, type cmd and hold down Shift + Control as you hit the
Enter key.
A User Account Control dialog box appears.

12. On the User Account Control dialog box, click Yes. The Administrator
command window opens.

13. On the command line (in the Administrator command window), navigate to
the folder where Unibar ELS Enterprise is installed and run the
installService.bat file.

For example: If you installed the application to the Program Files folder on
your C drive, type the following commands.

• c:

• cd \“Program Files”\Unibar\ELSEnterprise9\bin

• installService.bat

Note: When typing in the command prompt, you must use quotation marks around
any folder that has a space in the name.

Note: If you receive an error when installing Unibar ELS Enterprise as a service,
check the permissions on the Unibar folder.

14. At the Start menu, select All Programs > Admin Tools
If you do not see this on your Start menu, open the Control Panel, then open
the Administrative Tools folder. Finally, open the Services folder.

15. In the Services window, right-click ELSEnterprise and select Start.
The Status column will change from being blank to reading “Started” once the
application has been started.

16. Open a web browser and enter the following address:
http://[server name]:[Port name]/ELSEnterprise
For example: http://localhost:9010/ELSEnterprise

Note: You have the option to change the name of the service before installation by
opening the setVars.bat file in the bin directory and changing SetServi-
ceName=ELSEnterprise to a different name (SetServiceName=newname).
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 To stop the application (stand alone installation)

1. Navigate to the bin folder.

2. Right-click on stopELSEnterprise.bat.

3. Select Open.

The Apache Tomcat command window will close.

 To stop the application running as a service

1. Confirm that you have Administrative privileges.

2. Navigate to the Services Manager window.

3. Right-click on ELSEnterprise and select Stop.

 To uninstall the application as a service

1. On the command line, navigate to where you installed the application.

2. Navigate to the bin directory and run uninstall.bat.
Unibar ELS Enterprise will be shown as disabled. Windows will actually
remove the program files on the next system restart.

Note: For the Windows 7 operating system, you must have administrator privileges
and navigate to the command line with the following steps.

• Open the Run menu (Windows key +R).

• Type cmd and hold down Shift + Control as you hit the Enter key.
A User Account Control dialog box appears.

• Click Yes.
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 Downloading and installing Unibar ELS Enterprise for
Linux/UNIX

1. Download the appropriate file for your system.

2. Open a terminal and navigate to the directory where you want to install the
application.

3. Move the downloaded tar.gz file to this directory.

4. Unzip the tar.gz file, which will include JRE and Tomcat files, both of which
are required to run Unibar ELS Enterprise.

5. Navigate to the bin directory.
({Directory where you installed application}/Unibar/ELSEnterprise9/bin) .

6. Type chmod +x *

7. Type './startELSEnterprise.sh'
The './' is required if the install directory is not in the path.

8. Open a web browser and enter the following URL:
http://[server name]:[Port name]/ELSEnterprise
For example: http://localhost:9010/ELSEnterprise

Note: Adobe Flashplayer 10 or later is required to run the application’s graphical
user interface.

Note: The 32-bit Unibar ELS Enterprise application will run on both 32 and 64-bit
systems. The 64-bit application is only for 64-bit systems.
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Logging In

Following the initial installation of the application, you will be running in
Demo mode.

 To access the application prior to installing your license

1. From the User ID drop-down list, select Admin.

2. In the Password field type dsi (all lowercase).

3. Click Login.

To explore the application prior to activating a license select Run in Demo
Mode.

Licensing

On the Licensing pages you can access your license information and settings.

To navigate to the licensing pages, from the application header select Admin
> Licensing.

Licensing Agent schedule settings can be set in the Licensing module on the
License Settings page. The Licensing Agent retrieves your license key from a
Web service hosted at DSI.

Demo Mode

If you launch the application and do not enter license information, the applica-
tion uses a demo key. Unibar ELS Enterprise displays a reminder that you are
running in Demo mode at the top of the application window. In Demo mode,
the printed version of your label will have at least one characters in each field
of a barcode changed (or obfuscated) when printed. This change will not
affect the size of any of the fields, but it will make the label unusable in pro-
duction. In Demo mode, you only have the ability to add 10 printers for use.
RFID labels can be designed, but they cannot be printed in Demo mode.
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 To automatically update a license

Begin at the License Status page.

1. Click the Update License Automatically button.

2. Enter the License ID.

3. Click Submit.

If the License Key is generated successfully the Login screen appears.

If your license ID has been previously used or is invalid an error message dis-
plays.

 To manually update a license

Begin at the License Status page.

1. Click the Manual License Entry button.

2. Enter the License ID.

3. Click Create License Key.

4. Once you receive the License Key information, email it to DSI at globalsup-
port@dsionline.com.
DSI will then provide you with additional license information.

5. Paste the license information into the lower field of the License Generation
dialog box.

Click Submit.
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Printers

Selecting Printer Models

Before you can design or print a label you must select which printer models
will be available to the application. The number of printers that you can make
available is determined by your license.

 To set the available printer models

1. Navigate to the Printer Model Configuration page.
(From the application header, select Design > Printer Models.)

2. To select the printers to be used when printing labels, click the name of the
printer model in the Available Printer Models list.

3. Click the right arrow in the center of the window and the printer model will
appear in the Installed Printer Models list.

4. Click Save.

 To add a printer destination

1. Navigate to the Printers page.
(From the application header, select Admin > Printers.)

2. Click the Add button.
The Add New Printer dialog box appears.

3. Select the Type of printer you are adding from the drop-down list
(Device, Pipe, or File).

4. If the Type selected is Device or Pipe, enter the Logical Name and Device
Name.
If the Type selected is File, enter the Logical Name and File Name.

5. Click Save.
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When adding a printer the following attributes must be defined.

Field Description

Type DEVICE: A printer connected directly to I/O devices via
COM port, parallel port, or a shared printer, and are
designated as
/dev/lp0, /dev/tty1a, and so forth.

PIPE: A printer accessible via a server address; uses
either lpr in UNIX or the pipelpr utility provided with the
WIN32 installation package. This method requires the
print-server name or address and the internal name of the
printer to work properly.

FILE: Select this option when the label output is a *.jpg or
*.png file to be reviewed electronically, rather than a physi-
cal label. This printer type is often chosen when a label
image needs to be archived.

Logical Name Sets a name, assigned by the user, which is the name
used to refer to the printer. Logical name can be any useful
name, such as ACCOUNTING or DOCK_10 and is a text
string of up to 40 characters.

Note: The Logical parameter cannot contain any com-
mand line delimiters (space, comma, equal sign, slash,
etc.) that can be used on the command line.

Device Name Specifies the physical name of the printer.

File Name When the printer type File is chosen, this field must be
populated with the name with which you wish to save the
label file as well as location.

By default all labels produced as image output are saved in
the Output directory.

The ':' and '..' characters are not allowed in this field.
Absolute paths cannot be used for this field.

Shell Command For PIPE destinations only. This field contains the shell
command line that is passed to the system when opening
the pipe stream. Example: lp –d PrintQueueName
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Design Module

The Design module is made up of the Label Designer and the Data Dictionary.
The Label Designer allows you to access existing, or create new label tem-
plates. The Data Dictionary allows you to define label field definitions that
can be assigned to label templates and used to populate fields on printed
labels. With the Label Designer you can integrate barcodes, data, text, lines
and other graphics. Click-and-select menus make it easy to modify designs
and adjust font, size, density, and height.

The easiest way to generate a label is to start with an existing label template
and modify it to your needs.

 To open a label template

1. From the application header select Design > Label Designer.
The Label Designer page opens.
On the left-hand side of the screen is the Label Template Browser, which lists
the pre-loaded templates that come with the application. If the label template
browser is not visible, click the expansion arrow on the Label Design Toolbar.

2. Double-click Demo.Laser.

The template appears on the label canvas.

Note: Only templates that correspond with your installed printer drivers will open. If
the Demo.Laser template will not open, open the Printer Module Configura-
tion page and confirm that “PCL5-HP LaserJets & Compatibles (Recom-
mended)” appears on the Installed Printer Models list.
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 To insert fixed text

1. From the Label Designer menu, select Insert>Text Field.

2. Click on the label canvas where you want to insert the text.

A text box appears on the label template. Note that the text insertion option
stays selected for easy insertion of additional text boxes.

3. Under Text Properties you may enter the text you want to appear on the label
in the Text field.

4. From the main menu, select File > Save.

Note: You can delete label elements by selecting them with your cursor and pressing
the keyboard delete key or the delete button on the Label Design Toolbar.

Formatting Text

When you use the Label Designer to design a label template you can format
text with bold, italic, underline or reverse properties. These attributes can be
found in the Text Properties panel. Text must be selected for the Text Proper-
ties panel to be visible. Select the checkbox next to an attribute to apply the
formatting to the selected text. You will not see the text format changes
reflected on the user interface. Formatting text can be confirmed when labels
are printed.

Graphics

Color and grayscale images are not supported by label printers. Therefore,
this application supports 1-bit image files in the *.pcx formate. If your printer
supports *.png, *.jpeg or *.jpg files, these file types can be used on label tem-
plates associated with compatible printers.
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 To insert barcodes, RFID tags, or graphics

1. From the Label Designer menu, select Insert.

2. Select the element you want to add to the label template.

3. Click on the label template where you want to insert the element.

The insertion option stays selected for easy insertion of additional elements
until you click the selection tool on the Label Design Toolbar.

Note: RFID labels can be included in label template designs when working in Demo
mode, but the actual label cannot be printed.

 To adjust placement of text, barcodes, RFID tags, or graphics

1. Select the element you want to move with your cursor. Keeping the mouse
button pressed, drag the element to the desired location on the label canvas.

2. You can also adjust placement of an element on the label canvas by using the
X and Y sliders or arrows in the Properties panel located on the right side of
the page.

Note: You can also delete label elements by selecting them with your cursor and
pressing the keyboard delete key or the delete button on the Label Design
Toolbar.
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QuickLabel
The QuickLabel function provides for immediate label printing from screen
input or data file selection using an existing label template. This functionality
is useful for testing label designs before master label templates are finalized
as well as printing on-demand labels.

 To access the Quick Label module

1. From the application header, select Print > QuickLabel.
The QuickLabel page appears.

2. Choose a label template from the QuickLabel Browser.

3. Select the Data Entry radio button.

When you open a label template in QuickLabel, you see all the variable fields
listed that are available in the template along with the default values for each
variable.

4. Change the values for each field by typing directly into the field.

5. To print the label, select a printer from the drop-down list and click Print.

Note: You can also process data files using QuickLabel.

 To process a data file using QuickLabel

1. Set up a TXDATA field in the Label Data Dictionary.

More information about setting up fields in the Label Data Dictionary can be
found in the online Help.

2. Select the label you want to use by double clicking the name of the label tem-
plate on the QuickLabel Browser panel

3. Click the Print Job radio button.
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4. From the drop-down list, select the data record (which will populate all the
label field information).

Data records must be defined as a TxData field type in the Data Dictionary
before they can be used via QuickLabel.

5. Select the Merge File.

6. If the Merge File you wish to use is not listed, click Upload File and navigate
to the desired file.

7. Indicate the delimiter for the data file. The delimiter sets the field separator
being used for the data file indicated in the Merge File field.

8. Select a printer from the drop-down list and indicate the number of copies you
want printed.

9. Click Print.
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Mapping Labels to Alternate Printers

With Unibar ELS Enterprise, you can use an existing label design for more
than one type of printer. The need for an existing label to be used for multiple
printer types could arise when there are hardware upgrades or there is a need
to print in multiple locations. Label mapping allows you to assign a label tem-
plate to an additional printer. The label template must be given a new name
each time it is assigned to a new printer. Multiple label templates can refer-
ence the same Label Data Dictionary.

You access label mapping, when a label template is open, by selecting
File > Save As on the Label Designer.

When you select File > Save As on the Label Designer, the choices presented
on the Printer Model drop-down list are limited to those that support the same
fonts used on the open label template.

Label Data Dictionary
A Label Data Dictionary stores label field information for your label tem-
plates. Various field types determine the operations to be performed by the
Label Formatter when printing. These field definitions can be reused in multi-
ple label templates, speeding label template development and improving con-
sistency. More information about using the Label Data Dictionary can be
found in the online Help.

Note: Each label template must have a printer destination associated with it.

When designing a label template on the Label Designer, if you insert a label
Data Dictionary field, the sample data is displayed on the screen.
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